0

Support iSP100 FAQ

What Android version is required for the SmartPlug?

Android KitKat 4.4 or latest